This tutorial will take you through the process of creating an animated plasma membrane using Maya's unique Paint Effects module. Much of the tutorial will be focused on how to create a custom brush starting with the Paint Effects base brushes that ship with Maya. Paint Effects are ideal for situations in which a very large number of objects need to be seen from a distance (in this particular situation, the number of lipids on the surface of the membrane). Let's start by designing the brush.

Creating a Base Stroke

Designing a custom Paint Effects brush requires the adjustment of a myriad sliders and attributes. The process is not terribly straight-forward. The best way to learn is get an idea of how the paint effects controls work and then experiment. As you gain experience you'll find yourself becoming more comfortable with creating brushes. However, no matter how much experience you have, working with Paint Effects will almost always come down to trial and error with all of the various settings. This section of the tutorial is a walk-through of a typical custom brush design exercise. I will explain the controls that I use and what I hope to achieve when adjusting their settings. There are many ways to create a particular effect using a brush, the methods I describe are just a few.

1. Create a new Maya scene, this scene will be the devoted to designing the brush, once you have something satisfactory, you can export the brush from here to any other scene.

2. Create a Polygon plane, scale it up so that its about 2 x 2 units, set the subdivisions in width and height to 4.

Figure 1: Polygon Plane is created for the purpose of testing brushes.

3. Switch to the Rendering menu set. Select the polygon plane and choose Paint Effects>Make Paintable This needs to be done whenever you paint on a surface; otherwise the strokes appear on the grid.

4. Open the Visor (Windows>General Editors>Visor). This is where you'll find presets for Paint Effects, Fluids, Hair and other Maya effect modules. Its best to start with a Paint Effects preset when you're first learning Paint Effects. Its rare that you'll run into a situation where you'll ever need to make a Paint Effects brush completely from scratch.
5. Select the Grasses folder on the left side of the Visor window. Click on the Cattails brush a couple times until it turns yellow, this will load the cattails brush into memory as the current brush.

Figure 2: The Visor contains hundreds of Paint Effects presets. The preset icon turns yellow when selected, indicating that it has been loaded into memory.

6. The Paint Effects tool should become active when you click on the cattails brush icon in the visor, if it doesn't choose Paint Effects>Paint Effects Tool, the cursor should look like a small pencil.

7. Use the Paint Effects tool to draw on the polygon plane. The cattails will most likely be very large.

8. Select the strokeCattail1 in the Outliner and open the Attribute Editor, select the tab labeled cattail1 and set the GlobalScale slider to .3. This will make the size of the stroke a bit more reasonable.

Figure 3: Reducing the Global Scale of the brush brings the stroke down to a more manageable size.
9. Select the plane and hide (ctrl+h) it so that you can focus on the strokes.

Paint Effects Nodes

Before continuing its a good idea to take a look at how the network of nodes that are created when you paint a Paint Effects brush stroke in a scene. Since many of the settings reside on several nodes you’ll need to know where to look as you adjust the settings for the stroke. Open the Outliner, at the top menu of the Outliner uncheck Display>DAG objects only. This will allow you to see all the nodes in the scene. Select the strokeCattail1 object and open the Hypergraph (Window>Hypergraph: Connections). You’ll see the network of nodes that make up the cattail stroke.

Figure 4: Turning of “Display DAG Objects Only” in the Outliner allows you to see all of the nodes in the scene in the Outliner.

By now you should be familiar with the typical Transform and Shape node relationship. The Transform node holds information about size, scale, visibility, and other standard positional information about a Maya object, the shape node holds information about the history, input connections and other information specific to the type of object.

A Paint Effects brush stroke has a transform and a shape node as well as a connection to the template brush settings. In the Hypergraph you can see the cattail1 transform node (labeled strokeCattail1), the shape node (labeled strokeShapeCattail1) and the brush node labeled cattail1. Note that there is also a curve input connected to the shape node, this curve is created when you paint a stroke on a surface, it is hidden by default.
**Figure 5: The Hypergraph shows the relationship between the nodes that make up the Paint Effects Stroke.**

In the Outliner you'll see a cattail1 and a cattail node. The cattail node is a template created when you paint a stroke in the scene, its not visible in the scene. Changing the settings for this node will not affect the strokes already painted in the scene, however the changes will affect the next stroke you paint in the scene. For the most part, to keep the workflow simple, you can ignore this node.

When developing a custom brush you'll want to concern yourself with the settings on the shape node (strokeShapeCattail1) and the stroke node (cattail1). You can safely ignore the Transform node (strokeCattail1) and the template node (cattail).

**Editing the Stroke Shape**

I chose the cattail brush as a starting point because it is similar to the final phospholipid shape - it has a long stem an a bulging area at the top. With some tweaking, the bulging area can be turned into the hydrophilic end of the lipid and the tail can be turned into the hydrophobic end. In this case the tail is a single strand as opposed to the double tail typically shown in illustrations, however for this particular shot the membrane will be at a density where that particular detail will be lost. Later on I’ll describe a method for creating a double tail lipid.

1. Select the strokeCattail1 object in the outliner and open the attribute editor, open the cattail1 tab. The Global scale has already been set to .3 which has reduced the overall size of the brush.

2. The cattail brush, like many others, uses tubes to create each individual cattail. To get a sense of what this means scroll down in the Attribute editor to the Tubes rollout, expand the Tubes rollout and uncheck tubes to turn the tubes off. Immediately you'll see the cattails disappear, the brush is now a simple 3D stroke that follows the original stroke you painted on the surface. Turn tubes back on, the cattails reappear. A simple brush without tubes is ideal for simple pen strokes or toon lines. Tubes are like a group of smaller strokes that grow within a certain radius of the original brush stroke, like a strip of flowers that grow along a path. Many of the settings used to customize this brush will be found in the Tubes section of the attribute editor.

**Figure 6: The same two strokes with (left) and without (right) Tubes activated.**
Paint Effects settings are often interdependent, changing one setting can sometimes affect how another setting is applied to the brush, for this reason you’ll find yourself jumping around between menus fairly frequently, there is no set order for how the attributes are edited. Also, keep in mind that any attribute can be changed at any time and the stroke will be updated accordingly. Most attributes can be animated using key frames or expressions, which can lead to some interesting behaviors.

3. Make sure that Tubes and Tubes complete are both checked in the Tubes section of the Attribute editor. Tubes Complete ensures that all the tubes created with the stroke are "fully grown" when drawn, otherwise the lengths of the tube will diminish towards the end of the stroke which can be desirable for some effects.

4. In the Creation rollout below the Tubes settings, set the Tubes Per Step attribute to 2. This increases the number of tubes generated for each point on the curve created with the stroke. You can greatly increase the density of the stroke at any time by increasing the tubes per step - beware, if you decide to convert the stroke to polygons or NURBS later on, a very dense brush will translate into a lot of geometry which can cause problems when rendering. Keep in mind the level of detail you think you'll need for the particular shot you want to create.

5. Set the length Min and length max to 0.5 so that all of the tubes are the same length. Min and Max define a range for the tube length. Individual tubes are assigned these lengths at random.

6. Set the tube width 1 and width 2 to 0.015. Width 1 controls the width of the tube at the start, width 2 controls the width of the tube at the end.

Figure 7: Adjust the settings under the Creation rollout changes the overall look of the stroke.

7. To straighten out the tubes, adjust the settings in the tube directions setting. Set Tube Direction to Along Normal (it should be set to this by default) so that the tubes align themselves according to the normals of the surface they have been painted on.

8. Set Elevation Min and Max to 1, this will cause the tubes to point straight upwards. Azimuth controls the rotation of the tube direction based on the tubes origin. This setting has no effect when the elevation is set to 1. The tubes are straighter – not perfectly straight though, you'll see why in a few more steps.

9. Expand the Growth roll-out, you'll see that both Branches and Flowers are checked. If you uncheck branches you won't notice an immediate change, we'll take a look at this more in a moment. Unchecking the flowers option removes the heads of the cattails. The round shape of hydrophilic ends of the lipids will be created by adjusting the settings under the Flowers controls. Make sure Flowers and Branches are checked again before moving on.

10. In the Attribute editor, scroll down and expand the Flowers settings. Leave petals in flowers and num petals at 1. set petal dropout to 0 and flower locations to "on all"
11. Set petal length to .018, petal base width to .127 and petal tip width to .145. How were these settings determined? Trial and error. The settings themselves are fairly self-explanatory. The cattail end is created by tightly wrapping a typical flower brush so that it forms a cylinder. If you adjust these settings on a more typical flower stroke, such as the daisy stroke, you'll see that petal length controls how long each petal is, petal base and tip width control the width of each petal at the base and tip.

*Figure 8: Adjusting the Flower settings changes the look of the cattails at the end of each tube.*

12. To further refine the shape of the flowers you can add points to the Petal Width Scale graph. Click on the arrow next to the graph to expand the window this will make it easier to work in.

13. To add a point to the graph, click on the line at the top of the graph, to remove a point click on the box below the graph that corresponds to each point. Add three points to the graph... drag the points at the start at the end of the graph down to zero, move the two middle points towards the center. You'll see the shape of the flowers become pointed at either end.

14. Select the first point on the left side of the graph and set the interpolation to spline. This affects the shape of the curve to the right of the point. Select the other points point on the graph and set their interpolation to spline as well, now the shapes of the flowers are a bit rounder. Experiment with the position of the points on the graph and see how it affects the shape of the flowers. When you have something you like, feel free to move on.

*Figure 9: Changing the Petal Width Scale Graph causes the cattail ends to become rounder.*
This tutorial will only cover the settings that are needed to create the look of the lipids in the membrane, however, as you go along you may want to experiment with some of the other settings, such as Flower start and Flower angle, just to see what they do, just be sure to set them back to their original setting before moving on.

15. Scroll down and set the petal segments to 5. Paint Effects Tubes are made up of segments - a segment in a tube is roughly analogous to a polygon in a mesh, the more segments you have, the denser the tube and more detail is available for the tube. Its best to balance the number of segments used in your tubes to make sure you only have as much as you need for a particular shot to optimize rendering.

16. Scroll back up to the Creation section of the Tube settings and set the tube segments to 6. This sets the number of segments used for the hydrophobic stems of the lipids. Notice that the strokes get a little straighter.

17. Set Segment Width Bias to .164. This setting controls how segment width affects segment length. Positive numbers make wider segments longer while negative numbers make wider segments shorter. In the case of our brush, a setting of .164 causes the flower to become a bit squatter and rounder. Again, this was determined largely through experimentation. You can see how settings in the tube section can affect the tubes as well as the flowers. This shows how many of the settings are interdependent.

Creating Branches

Now that the basic shape has been defined the real trick to this brush is finding a way to paint both sides of the membrane with a single brush. Then you can coat any surface using one stroke and the entire membrane will be created. One way to achieve this is to create a branch from the tube that is rotated 180 degrees from the original tube which will create a mirror image of the original stroke.

1. Scroll up to the Growth section of the Tubes settings and make sure Branches is checked.

2. The Start Branches setting controls the number of branches at the root of the tube. After some experimentation I discovered a setting just above 1 worked well. Set Start Brushes to 1.091.

3. You only need one branch to create the mirror image so set num branches to 1.

4. Branch Dropout automatically prunes branches to create a natural random look. In this case pruning is not desirable, so set branch drop out to 0.

5. Scroll to the bottom of the branches section and turn on Middle Branch - this continues the main branch of a stroke beyond the branch spilt. Its not obvious how this creates the effect needed for this particular but without this turned on, the mirror image is not created. Once again, this was discovered through experimentation.

6. Now, to create the mirror image set Split Angle to 180. The result is a single brush that creates both sides of the lipid bilayer. Of course, each lipid has only a single straight stalk as opposed to the two tails normally shown in diagrams of the membrane. However we're counting on the fact that this stroke will be densely painted on a surface to the point where it will be difficult for the viewer to detect that each lipid only has a single strand. later on in this tutorial I'll demonstrate an alternate approach to creating a brush that has two strands instead of one.

Figure 10: Adjustments made to the branch settings creates a mirror image for each tube, this way both sides of the membrane can be painted with a single stroke.
To see an example of the scene so far, open the paintEffectsMembrane_1.mb file.

**Adjusting the Brush Colors**

Before creating the membrane surface you'll adjust the colors of the brush. The colors are set in the stroke attributes and there are separate settings for the flower and the tubes.

1. In the attribute editor for the stroke, scroll up above the Tubes section to the Shading rollout. Expand this section. Click on the color swatch for under shading and set this to bright orange.

2. Expand the tube shading section and set the color swatch to a similar bright orange.

*Figure 11: The color settings for the stems of each tube is found in the shading section.*
3. Scroll down to the Flowers section within Tubes. Find the Petal 1 and Petal 2 color swatches, set these to yellow. You can also experiment with the translucence settings on the flowers as well as the transparency and HSV randomization.

4. Zoom out and create some test renders, adjust the colors until you're happy. You may also want to tweak some of the brush settings. I increased to tube Width 1 and 2 to 0.035 and the Petal Base Width to .227 and Petal Tip Width to .173.

5. Set Tubes per step to 25 and do another test render to see what a denser membrane will look like.

6. Save the scene, the brush settings will be saved with the scene. You may want to rename the brush.

*Figure 12: With some additional color changes and tweaks, the stroke is starting to show potential as a membrane*

---

**Adding Motion**

Paint Effects strokes have random motion built into the stroke which can add additional life to the animation.

1. Scroll down to the Behaviors tab, set Path Follow and Path Attract to 0. This will straighten the tubes. The Path is the original curve used to generate the stroke.

2. Set Random to .055. This will add a little chaos to the arrangement.

3. In the Turbulence section set the Turbulence type to World, Interpolation to Smooth over Time and Space.

The Turbulence settings are an area ripe for experimentation, try different versions and then create a playblast for each. Here’s a quick rundown of what the settings mean:

Turbulence as a force causes the ends of the tubes to move back and forth as though the turbulence is moving laterally through the field of tubes. Turbulence as a displacement causes the tubes to bob up and down so the strokes are being displaced vertically. You can choose to have the turbulence force or displacement be applied in local or world space. World space is generally a better option if you want a
number of separate strokes to appear as though they are all affected by the same turbulence. Grass and Tree wind are similar in that the turbulence affects the ends of the tubes more that the roots so that it appears that the strokes are blowing in the wind. Grass wind affects the tips of the tubes, tree wind affects the tips of branches, both forces are applied in world space.

The interpolation adjusts the quality of the turbulence. A linear setting causes a more jerky random motion, smooth over time and smooth over time and space create a more natural motion. Smooth over time and space offers the highest quality while linear and smooth over time work better for higher turbulence speeds.

4. Save the scene as membraneStroke.mb

To see an example of the scene so far, open the paintEffectsMembrane_2.mb file.

**Creating a Membrane Using nCloth**

Now that you have a basic lipid brush you can create a dynamic surface to paint them on. This part of the tutorial uses basic Maya nCloth. This section requires Maya Unlimited.

1. Create a new Maya Scene.

2. Create a polygon surface, scale it up so that the plane is 10 units in height and 10 units in width.

3. Set the subdivisions width and length to 36.

4. Set the time line length to 600

5. Switch to the nCloth menu set, select the cloth and choose nCloth>Create nCloth.

6. Play the animation, you'll see the cloth start to fall. nCloth has gravity built into its dynamics.

7. Select the nCloth1 object, Open the attribute editor and select the nClothShape1 tab.

8. Scroll down and set the mass to .2.

9. Select the nucleus tab, set the gravity to -1.

10. With the nCloth object selected, switch to the Dynamics menu set and create a turbulence field (Fields turbulence). By creating the field with the nCloth object selected you automatically attach the field to the nCloth object.

11. Select the Turbulence field, set the magnitude to 5 and the attenuation to 0. Rewind and play the animation. The cloth object no longer falls as fast but the turbulence causes it to fly off into space. We'll create some constraints to tie it down.

*Figure 13: The turbulence field causes the cloth object to crumple and fly away.*
12. Create another polygon plane. Scale it to 10 in X and 1 in Z. Set the width divisions to 36 and the length divisions to 1.

13. Move the new plane so that it is adjacent to the nCloth plane, leave a small gap between the new plane and the nCloth object. Duplicate this plane and move it to the other side.

*Figure 14: Two long, thin planes are placed on either side of the cloth object.*

14. Switch to the top view, set the mode to component mode. Select the nCloth object, you should see its vertices highlighted, select one of the long thin planes as well so its vertices are highlighted. You want to select the adjacent rows of vertices on the nCloth object and the long thin plane, use a selection box (drag while holding ctrl+shift) to select them both at once - the selected vertices will turn yellow.
15. From the nCloth menu set choose nConstraint> Component to Component. This will create a series of constraints between the two sets of vertices as well as automatically convert the long thin plane to a passive dynamic object. Rewind and play the animation, you’ll see the nCloth object tethered to one of the long thin planes.

Figure 16: The row of constraints causes the cloth to be tethered on one side.

16. Rewind the animation and repeat the steps for the second long thin plane on the other side.

17. Play the animation, now the nCloth object is held between the two long thin planes. To give the nCloth object more of a constant motion, select the Turbulence1 field, right-click on the Phase Y attribute and choose "add Expressions". In the expression editor add the following expression:
turbulenceField1.phaseY=noise(time);

This causes the phase of the turbulence field in the Y direction to be constantly varied between -1 and 1 using a noise function.

18. Play the animation and experiment with different settings in the nucleus tab and the ncloth tab. To slow down the motion of the nCloth, increase the drag or try adding some wind using the wind parameters. When you are happy with the basic movement of your cloth, save the file as clothMembrane_1.mb.

*Figure 17: The cloth is now constrained on either side.*

---

**Adding the Lipid Stroke**

To apply the lipids to the cloth object you can simply grab the settings from the stroke you created and paint them on the nCloth plane.

1. With the nCloth scene open choose File>Import and import the paint effects stroke (membraneStroke1.mb) scene. You'll see the stroke appear on the polygon plane.

2. In the Outliner, select the stroke (strokeCattail1) and rename it lipidStroke.

3. Select the Cloth object, from the Rendering menu set choose Paint Effects>Make Paintable.

4. In the Outliner, select the stroke and choose Paint Effects>Get settings from Selected stroke. This will load the settings for the lipid stroke into memory.

5. Choose Paint Effects>Paint Effects Tool and start painting on the surface of the cloth object.

**Optimizing Stroke Display**

You'll notice the display of the strokes is fairly quick as you paint however things will slow down when you let go and Maya tries to display the stroke as a mesh. There are a couple things you can do to remedy this.

1. In the Outliner, select the objects you imported and delete them, now that you have the stroke painted on the cloth object you no longer need them.

2. Select the lipidStroke1 object and in the Attribute Editor for the shape node of the stroke (lipidStroke1Shape), turn off the checkbox next to Display as Mesh.
Figure 18: The lipid stroke has been imported and used as a template for painting on the cloth object. The painted strokes have their mesh display set to off so that they can be displayed properly on the cloth.

3. Alternatively (or additionally depending on how heavy the scene is) you can also set the Display Quality to a lower number, such as 25,

4. Changing the "Display as Mesh" and "Display Quality" settings will not effect how the stroke render, only how they are displayed in the scene.

5. Continue to paint strokes on the plane. Note that the settings for each stroke are on the Shape node, not in the stroke settings themselves so you will have to change them for each stroke after you paint.

If you have a large number of strokes in the scene and you’d like to change the display quality on all of them at once, you can select all of the shape nodes for the strokes in the Outliner (make sure the Outliner is set to display shape nodes) and then open the Attribute Spreadsheet (Window>General Editors>Attribute Spreadsheet). Under the Shape Keyable tab you can shift select the column for Display Quality and change the settings for all the strokes at one. You can also select the Display As Mesh Column and enter 0 to turn all of the Display as mesh settings off.

Maya has an automatic limit to how many strokes can be displayed in the scene. If you find that a large portion of your stroke has disappeared after you've drawn it on the object, check the script editor and see if you get a message like the following: "// Warning: strokeShapeBrush11 was only partially drawn (for hints see doc for Paint Effects: displayMaxDrawSegments). //" The strokes still exist but they can’t be displayed, changing the Display Quality setting and the Display as Mesh setting on the shape node should fix this so that you can see the entire stroke in the scene.

6. The show menu in each view will allow you to toggle on and off the display of the strokes, this can be helpful when working on other parts of the animation that do not require that you see the strokes. Of course you can also put the strokes on a separate display layer to control their visibility while working.

7. Once you have some strokes painted in the scene, you can delete the imported lipid strokes and the plane that came in with the scene.

**Brush Sharing**

If you have a large number of the same stroke in a scene and you decide you need to make a global change to all of them, you can use brush sharing which will treat all the strokes in the scene as one so that changes
can be made easily.

1. In the Outliner, select all of the stroke objects. Choose Paint Effects>Share One Brush.

2. Select one of the brushes in the Outliner and switch Brush tab. Make a slight change to the Global Scale, all of the strokes that are shared will inherit this change.

*Shared brush attributes do not include those settings found in the Brush’s shape node such as Display Quality, or Pressure Mappings. The shared brush settings are only the ones on the Brush node - those settings used to create the overall look and behavior of the brush.*

**Rendering Strokes**

You have the option of converting the strokes to Mesh or NURBs objects if you want to render with Mental Ray, however because of the density of the strokes is very high, it would probably be easier for you and your machine if you render as strokes using Maya software. If this membrane shared the scene with objects you’d like to render using Mental Ray or Maya hardware, you can use render layers and composite the scene elements together after rendering.

1. Select the cloth plane object and hide it (ctrl+h) so that only the strokes are visible.

2. Open the render settings window. Set the renderer to Maya Software.

3. Set the Quality Presets to Production Quality.

4. Scroll down to the Paint Effects Rendering options. Make sure that Enable Stroke Rendering is on so that the strokes render properly.

5. Enabling Oversampling will improve the quality of the render somewhat - in the case of this stroke it causes the surface of the membrane to appear thinker in distant parts. It may add 10 to 30 seconds to the render time of each frame.

6. Turning on "Only Render Strokes" will cause only the strokes in the scene to render, no geometry will be visible. In some situations this can be quite helpful, just be mindful that and occluding geometry objects will not render.

*Figure 19: A nice solid lipid bilayer is rendered using Maya software.*

If you render a sequence of the scene, be sure to create an nCache for the nCloth surface, especially if you render on a network - make sure that the cache is on a machine that the network can see.

To See an example of this scene, open the clothMembrane2.mb file.
Alternative Membrane Stroke Techniques

In this section you’ll take a different approach to designing a membrane using a Paint Effects stroke.

1. Create a new Maya scene.

2. Create a Polygon plane, scale it up so that its about 2 x 2 units, set the subdivisions in width and height to.

3. Switch to the Rendering menu set. Select the polygon plane and choose Paint Effects>Make Paintable.

4. Open the Visor (Windows>General Editors>Visor). Click on the Plants folder and choose the onion.mel stroke.

*Figure 20: The Onion stroke is chosen from the Plants folder in the Visor.*

5. Paint a stroke on the polygon plane. Turn off the visibility of the plane once the stroke has been painted on so you can see how the stroke is affected by the edits.

*Figure 21: The Onion stroke is painted into the scene and the plane is hidden.*

6. Select the stroke in the Outliner and open the Attribute editor. Under the Onion1 tab set the following settings (if a setting is not specified you can leave it at its default value):
- Global Scale = .64
- Under Tubes make sure Tubes and Tubes completion are both on
- Set Tubes per stroke to .64
- Tubes rand and Start Tubes = 0
- Segments to 30
- Length min = .364
- Length Max = .455
- Tube width 1 = .029
- Tube width 2 = .005
- Width Rand = .15
- Width Bias = -.109
- Tube Direction = along normal
- Elevation min and max = 1

- Under the Growth settings both branches and flowers should be active.
- Under Branches set Start Branches to 1.455
- Num Branches = 1
- Split Max Depth, Branch Dropout, Split Rand, and Split Angle all set to 0
- Split twist = -.291
- Split Size Decay = .718
- Min Size = 0
- Middle Branch should be on

- Under Flowers, set Petals in Flowers to 5
- Num Flowers = 1
- Petal Dropout = 0
- Flower Locations = on all
- Petal Length = .191
- Petal Base Width = .127
- Petal Tip Width = .136
- Set the Petal Width scale to look like figure 21 - it should have 4 points, the interpolation of each point should be set to spline

Figure 21: The Width Sale settings for the flowers on the onion stroke.

- Flower Start = 0
- Flower angle 1 and 2 = 180
- Petal Twirl = 1
- Petal Segments = 7
- Petal Flatness = 0
- Flower Stiffness = .5

- Under Behavior set Displacement Delay = .746
- Noise = .145
- Noise Frequency = .5
- Curl = .083
- Curl Frequency = 3
- Path Follow = 0
- Path Attract = 0
- Random = .1
- Gravity = 0
- Momentum = 1

- Turbulence Type= World Displacement
- Interpolation = Smooth over Time and Space
- Turbulence = .145
- Frequency = .591
- Turbulence Speed = .627

These settings were arrived at through experimentation and certainly not in this order.

*Figure 22: The stroke settings create one half of the lipid bilayer:*

---

Creating the Bilayer

As you may have noticed, this stroke creates only one half on the bilayer. It also is the opposite of the stroke created in the earlier Paint Effects example - The hydrophobic tails are on the top as opposed to the bottom. Instead of creating one stroke that makes both layers you'll paint this stroke on two planes and then flip one of the strokes to make the bilayer, this approach has the advantage of allowing more detail in the tails, any approach you take is determined by the shot you are trying to create in your animation.

1. Scroll to the top of the settings for the onion1 tab, set the Brush Width to .5.
2. Scroll down to the Tubes section and increase the tubes per step to 4.
3. Select the stroke in the Outliner and choose Paint Effects>Get Settings From Selected Stroke.
4. Select the Polygon plane and duplicate it.
5. Move the duplicate up in Y so that it is above the original plane.
6. With the duplicate plane selected, choose Paint Effects>Make Paintable.
7. Paint more of the onion stroke on the duplicate plane.

*Figure 23: The stroke is painted on a duplicate plane above the original.*
8. Select all the onion strokes and choose Paint Effects>Share One Brush

9. Select the stroke applied to the top plane open the Attribute Editor to StrokeOnionShape3 tab. Turn on the Use Normal check box. This aligns the stroke to the normal of the surface it has been painted on.

10. In the fields for the Normal direction change the settings to 0, -1, 0.

11. Select the Strokes on the bottom plane, repeat these steps but set the Normal Direction to 0, 1, 0.

Figure 23: After setting the normal direction on the shape node for the brushes, the bilayer is created (The panes have been hidden in this image)

These settings are found in the shape node of each stroke so they are not affected by brush sharing. If you have created a lot of strokes in the scene remember that you can use the attribute spread sheet to quickly change attributes on multiple objects.
To see an example of this technique open the paintEffectsMembrane_3.mb scene.

**Converting to Polygons**

Paint Effects Strokes can be converted to geometry. This is helpful if you decide you need to render the scene using Mental Ray or any other rendering engine that does not support Paint Effects. There is a per-stroke polygon limit so if you know that you want to convert strokes to geometry you need to plan ahead when designing the stroke and painting objects in the scene. The converted strokes maintain a history connection to the stroke settings.

1. Select the first test stroke you created for the scene.

2. Choose Modify>Convert Stroke to Polygons> Options.

   **Figure 24: The options for Paint Effects conversion.**

   ![Options for Paint Effects conversion](image)

3. In the Options you can set the output to Quads which can be helpful if you want to edit the geometry directly just like a model. In this case you can leave Quad Output off, the resulting geometry will be comprised of triangles.

4. Activate Hide Strokes. The strokes will remain in the scene but will be hidden in the viewer and in the render. You can continue to tweak the settings on the strokes, as long as history is not deleted, the converted geometry will up date to reflect changes made to the strokes (this update can be pretty slow if the scene is heavy).

   The exception to this is the color settings applied to the strokes in the attribute editor. When you convert the strokes to geometry Maya will automatically create shaders that approximate the settings applied in the stroke’s attribute editor. You can edit these shaders or apply a new shader to the converted strokes. Just be aware that changing the colors in the stroke’s attributes will not change the colors of the converted geometry. If the stroke has transparency applied as part of the attributes, the resulting shader will try and replicate this transparency – sometimes this can look a little funny.

5. Set the Poly Limit slider as high as it will go. This limit is applied to each stroke - not the entire scene. When creating a stroke be aware of the segment settings for tubes, branches, petals, etc. These settings determine how many polygons will be used when the stroke is converted.

   When converting to polygons, Maya will do as much of the stroke as it can, any part of the stroke beyond the poly limit will be left out of the conversion. Since this is applied to each stroke, you may want to paint your scene with many small to medium length strokes rather than a few long strokes. This way you can ensure that all of your strokes are converted properly.

   You can also strategize when creating your scene so that a version of the stroke with much lower segment settings are placed in the background and more detailed/dense strokes are in the foreground, this will help ease the load on the scene and keep render times down to a manageable level.

6. Press the Convert or Apply button to make the conversion.
7. Once the strokes are converted you can edit the shaders applied to the strokes or create new shaders.

*Paint Effects strokes can also be converted to NURBS geometry, it depends on which you prefer and what is more appropriate for your scene. Converting to NURBS often results in a large number of NURBS patches for each stroke which can be a much heavier load on the processor. For scenes that require a large number of strokes you may want to stick with the simplicity of Polygons.*

**Suggestions for Animation**

This example requires two planes for each membrane as opposed to one plane as in the first Paint Effects example. To animate the planes together try the following using larger planes with more subdivisions:

1. Group the planes together and apply a deformer such as a lattice or a non-linear deformer to the group.

2. Create a third duplicate plane. Convert this third duplicate to a soft body or nCloth object. Use the third plane as a blendshape for both of the membrane planes.

**Further Study**

This tutorial is just the beginning. The procedural nature of Paint Effects strokes make them an ideal candidate to represent a variety of cellular structures. The best approach is to find a stroke in the Visor that you think might be fairly close to the shape of the structure you’d like to create and then experiment with the settings until you get what you want. Some other techniques to explore include applying strokes to preexisting curves, layer two or more stroke on a single curve, or experiment with stroke blending techniques.