Rendering for Compositing (in Maya 2011)

Using After Effects to composite image sequences rendered from Maya opens up a large number of possibilities and offers flexibility that is hard to achieve using Maya alone. While on the one hand a little extra work, foresight, and some knowledge of After Effects is required, the payoff for the additional effort is usually worth it. You don’t need to master every aspect of After Effects to take advantage of this workflow. A few simple tricks and techniques can add a lot of life and character to your animation. The techniques described in this tutorial are the same techniques used in design houses when creating animations for the entertainment industry.

Maya’s render layers are designed to allow you to break up a scene into passes for compositing. In this tutorial you’ll see how you can create custom render passes, use Maya’s render layer presets, and finally how to combine the rendered passes together in Adobe After Effects as a composition for final output.

Render Layer Basics

The Maya animation has already been created - you’ll use the scene file originally created for the dynamic parenting tutorial on MolecularMovies.org. This scene simply shows two proteins binding together, the proteins have some random motion added to their movements as they bind together. To keep things simple, the motion of the proteins, which was original created using fractal textures and constraints, has been baked into keyframes. The additional nodes have been deleted from the scene so you don’t need to worry about anything other than the basic animation. The only task you need to accomplish in Maya is setting up the render layers and rendering the various sequences for compositing.

The Render Layer interface is very similar to the Display Layer interface and working with them is initially the same. The point of a render layer is that you can assign specific objects to a render layer and when you start a batch render the objects on that particular layer will render as a separate image sequence and look and behave exactly as they do on that layer regardless of what’s going on in the rest of the scene.

The animation of an object can’t be different from one render layer to the next however the way an object looks can be exclusive to a render layer. An object on a render layer can have a different shader than the same object on another layer. You can also create different lighting for different layers, change the visibility of an object, and even have different render settings. You can render one layer using mental ray, another using Maya Software, or any other renderer. Render layers can have their own render feature settings such as ray tracing, final gather, anti aliasing settings, and so on. Ultimately there is a high degree of flexibility that can be accomplished with render layers.

The example scene shows two proteins binding. This will be used for the render layer example.
The art of knowing how to set up a render layer strategically comes with experience and experimentation. This example will provide you with one approach but there are many variations to this approach that you will discover on your own when creating your own scenes. To begin with you'll create render layers from an animated scene in Maya.

1. Open the compositing_v01.ma scene from the scene files. This scene has two proteins that are in the process of binding. The animation is complete for the scene and baked into the objects.

2. An animated camera and camera aim have been set up as well as a pair of directional lights.

3. The background in the animation is a polygon sphere with a Lambert texture applied. The Lambert texture has a 3D texture connected to its incandescence channel. The texture is a volume noise node, the 3D placement node of the texture has some animation in its translation and rotation channels. This will create the effects of rolling turbulent patterns in the distant background suggesting an organic cellular environment.

4. Each protein is made up of two objects; the outside is a mesh and the inside is a ribbon. The idea of the animation is to have the mesh as a semi-transparent object with the ribbon representation inside.

5. Switch to the renderCam in the perspective window and create a test render. It looks okay, it could certainly be improved with some more work in Maya. The transparency of the mesh objects is accomplishing the goal of the animation but its look is somewhat lacking in terms of style. Likewise the background is very detailed and distracting.

The original concept was to blur this background, which can be accomplished using depth of field in Maya, however this will add a great deal to the render time of the animation, particularly if the depth of field is to be rendered using metal ray. Furthermore, if it is decided that the blurring effect is too strong or needs to be changed, the entire sequence would need to be re rendered which is not terribly efficient. One of the greatest advantages of breaking the scene...
into render passes is that if an element needs to be changed, you can often, depending on how the scene is set up, isolate the one element that need to be changes and render it separately. Plus a simple blurring effect can be added in After Effects and tuned much more easily and quickly than the depth of field effect in Maya. While mental ray’s depth of field is superior to what you can achieve in After Effects, it should really only be used when absolutely necessary, when real photographic quality depth of field is required. Otherwise you should see what you can get away with using After Effects.

6. Make sure the channel box is open on the right side of the screen and that the display layers interface is visible in the lower right (there are no display layers in this scene - to keep it simple you won’t add any).

7. Click on the Render tab in the layer interface to switch to the render layer interface, you’ll see the default 'masterLayer (Normal)'. From the layers menu choose “Create Empty Layer”. When you do this you’ll see a new layer appear named ‘layer1 (Normal).’

The Master Layer exists in the scene at all times even when no layers have been added to the scene. It contains everything in the scene at its current state. All objects in the scene will always be members of the masterLayer. Generally you will not render the masterLayer when other render layers are added to the scene.

8. Double click on the layer1 label/word, in the dialogue box enter the name “proteinColor”. This layer will just render the color values you want to assign to the binding proteins.

9. Create another layer and name it “occlusion”. This layer will contain the shadowing information for the animation. In this case you’ll use an occlusion preset to apply ambient occlusion to the proteins.

Ambient Occlusion is a shadowing effect created when ambient light is blocked from entering or leaving small spaces in objects. It’s a very aesthetically pleasing effect. Think of a detailed marble statue on an overcast day, the shadowing in the nooks and crannies of the statue are a good example of ambient occlusion.
This type of shading when combined with the familiar X-Ray shading technique can create a very convincing EM Scanning look.

10. Create four new render layers, name them “Xray”, “Depth”, “Ribbons”, and “BG” (BG is just shorthand for “background”). The order of the layers does not matter, each layer is an isolated version of the scene.

11. As you click on each layer you’ll notice the scene elements disappear, this is because objects need to be added to each layer, click on the masterLayer and you’ll see the scene elements return. Click on the proteinColor layer. In the Outliner expand the ribo and inhibitor groups. Select the riboMesh object from the ribo group and ctrl+select the inhibitorMesh object from the inhibitor group.

12. In the render layer box, right click over the proteinColor layer and choose “Add Selected Objects”. The two proteins will be added to the render layer.

13. Select the riboMesh object while still in the proteinColor layer (you’re in the layer as long as it is highlighted in the render layer interface). Assign a new surface shader to the riboMesh object.

14. Name the new shader “riboMeshColor”. Set the out color to a bright orange.

15. Select the inhibitorMesh object while in the proteinColor layer, assign a new surface shader to this object. Name the shader “inhibitorMeshColor” and set the out color to blue.

16. Create a test render while in this layer using the renderCam (note that you can assign render cameras to render layers but you don’t have to, they will render the layer just fine even if they have not been assigned).

17. Without changing the time on the timeline switch to the master layer and render a frame. Notice that the shaders applied to the protein meshes on the master layer have not changed. The same object can have two completely different shaders applied on different layers.

18. Add the protein mesh objects to the Xray, Depth, and Occlusion Layers.

19. Add just the protein ribbon models to the Ribbons layer, add the lights to this layer as well.
20. Add the background sphere to the BG layer.
21. Save the file.

**Render Layer Presets**

In this workflow, we will use Maya’s (old) render layer presets (as opposed to the render passes system that was introduced in recent versions of Maya – render passes will be covered in a separate tutorial). Render presets provide you with a quick way to apply commonly used render and shader settings to all the objects in a render layer.

To create the ambient shading on the proteins you'll apply the occlusion preset to the occlusion layer.

1. Select the Occlusion layer in the render layer panel. Right-click over the layer label and choose ‘Attributes’ from the pop up window. This switches the UI to the render layer’s Attribute Editor – click on the ‘Presets’ button in the upper right and select ‘Occlusion.’
2. Create a test render while in the Occlusion layer. Maya applies the occlusion shader to the protein and sets the renderer for the layer to mental ray automatically.
3. Switch to the Depth layer and apply a Luminance Depth from the render presets using the same method. Create a test render.

Luminance Depth uses a special shader set up to shade objects based on their distance from camera. The closer the objects are to the camera, the lighter they become. As you'll see later on in the chapter, this special pass can be used in AfterEffects to create the depth of field blurring effect. The shader may require a little tweaking to establish a good range of values for this particular scene.

The shading is applied to the objects based on the clipping planes of the camera. By default all cameras have “auto render clip planes” activated. The clipping planes are set by the size of the scene detected by the camera. Currently only the protein meshes exist in the layer making the scene size appear quite small to the camera. Thus the shader doesn’t have much of a range to work with when shading the objects based on scene depth. There are a couple ways to fix this. You can turn “Auto Render Clip Planes” off in the camera’s Attribute Editor and then set the Far Clip plane value to a lower number. You could also take advantage of the background sphere that exists in the scene. By
adding the sphere to the depth layer you establish that the scene size is based on the size of the sphere.

4. Select the background object and add it to the depth layer.
5. Create a test render. The background appears as a light gray in the layer. What you want is for the background to be black and the proteins to move from dark gray to white as they approach the camera, preferably the details of the protein shapes will also be somewhat visible in the depth pass.

6. Select one of the protein objects while in the Depth layer. Open the Hypershade, right click in the work area and choose “Graph -> Graph Materials on Selected Objects”. You’ll see the special shader applied to the objects in the layer. You can tune the depth shader's sensitivity by adjusting the multiplier value in the multiply/divide node. Select the multiply/divide node, in the Attribute Editor, change the input2 value from -1 to -130.

7. Create another test render, the proteins are dark gray when they are far from the camera and appear lighter as they approach the camera. Notice that the renderer used in the Depth layer is Maya Software while the renderer used in the Occlusion layer is mental ray. Maya automatically sets the appropriate renderer for each layer based on the preset used.

**Setting Up For Rendering**

Setting up the final three layers is relatively easy. The Ribbons layer will contain the ribbon representation of the proteins that will be composited so that they appear inside the protein surface meshes. The BG/background layer will contain just the background and the Xray layer will contain the protein meshes with a typical Xray (facing ratio) shader on the objects.

1. Select the ribbon layer, this should contain the ribbons and a couple lights. You set this up in step 19 of the first section.
2. Click on the clapper icon next to the ribbon label in render layer palette this

![The Luminance Depth preset shades objects based on their distance from the rendering camera.](image)

![By adjusting the value of the input 2 attribute on the Multiply/Divide node you can tune the luminance depth shader.](image)
will open the render settings for this layer. Right click next to the "Render Using" menu and choose "Create Layer Override." This creates an override that will be applied to just the ribbon layer. Set the renderer to Maya Software.

3. In the Maya Software tab of the render settings window, set the quality preset to Production quality.

4. Repeat these steps for the BG/background layer.

5. Select the XRay layer. Select the ribomesh object while in the Xray layer. In the Hypershade find the riboXray shader and apply it to this object (simply right-click over the shader’s icon and choose "Assign Material to Selection" object). Apply the inhibitorXray shader to the inhibitorMesh object while in the XRay layer.

6. These shaders are lambert shaders that use the typical X-ray shader technique to apply a ramp to the incandescence channel of the shader. Create a test render and you’ll see the edges of the objects are brightly colored.

7. Save the scene.

8. Select the masterLayer render layer and open the render settings. You’ll see tabs for all of the available renderers in the scene. In the common attributes section make sure Maya is set up to render a sequence of 300 frames.

9. In the File Name Prefix slot type the "%s/%s_%l/%l". This is a special code that will organize the output of all ender layers into separate folders. The %s code stands for “scene name” and %l stands for layer name. All image sequences will be rendered to a folder named after the scene. That folder will contain a subfolder for each layer named “scene name_layer name” and within each of these folders the actual sequence will take its name from the layer name. This is important as it will help you understand the source of each layer once they are imported into After Effects.

10. Save the scene and start a Batch render.
Importing the Sequence in to After Effects

As you gain experience with creating animations using this style of workflow, you’ll develop a feel for what you need from Maya in order to create a great composition in After Effects. Essentially each of the rendered sequences becomes an ingredient rather than the entire meal and much of what you create in Maya is prep work to be seasoned and finessed in After Effects. This tutorial goes through some fairly simple techniques and only uses a few of the many effects found in After Effects. The student is encouraged to use these techniques as a launching pad for their own approach to compositing.

The easiest way to bring files into After Effects is to simply drag them into the application from the operating systems’s file browser.

1. Open After Effects (should create a new project by default).
2. Reduce the size of the After Effects application window so that you can see the desktop of your computer.
3. Use your operating system’s file browser to locate the image sequences folder rendered from the Maya scene created in the first section of this tutorial.
4. Open the folder so that the subfolders are visible.
5. Drag each subfolder into the Project palette of the After Effects interface. This will add each sequence to the project.
6. Once you have the sequences in After Effects save the project under the name “proteinBindingComp”. If you move this project later on, or if you relocate the folders containing the image sequences you’ll need to re-link each sequence in After Effects.
7. In the project palette, select the BG (background) sequence, drag it down on top of the filmstrip icon in the Project palette, this will create a new composition of the same length as the image sequence.
8. Add the proteinColor layer on top of the background layer in the timeline. It should have an alpha channel already so the background layer should be visible behind the proteins.
9. To remove the dark fringe from around the proteins, right click the proteinColor layer layer in the project window and choose Interpret Footage>main. From the pop-up box select Premultiplied and make sure the matte color is set to black.

10. Add the Occlusion layer on top of the proteinColor layer. The layer will appear black and white on top of the proteins. You really only want the shadowing to be added to the proteins, to achieve this you can set the blending mode to Multiply. This multiplies the pixel values below the layer by the pixel values in the layer. So where the occlusion layer has a pixel value of 1 (white) no change is seen in the pixels below it. If the pixel values are below 1 (such as .8) the pixel values below the occlusion layer are reduced thus making the darker. What you end up with is the occlusion shading applied to the flat color of the proteinColor layer.

11. The occlusion layer is a bit too strong, you can reduce its opacity by expanding the layer and lowering the opacity under the Transforms heading to 80%.

12. Drag the XRay layer on top of the occlusion layer in the timeline. Set its transfer mode to Screen. This works like the opposite of multiply, now only the light values of the layer are applied to the layers below. The XRay look combined with the occlusion pass creates a very stylistic EM scanning look.

13. Drag the ribbons layer on top of the XRay layer. The ribbons should look as though they are inside the protein mesh objects. There’s a number of interesting ways to achieve this effect:
   - Simply lower the opacity of the ribbons layer.
   - Or set the transfer mode to screen or overlay.
   - Or, to create the impression that the mesh objects are translucent, try setting the ribbon’s transfer mode to multiply, lower the opacity to 50% and then apply a Gaussian blur to the layer. To apply a blur, select the layer in the timeline and choose Effects>Blur & Sharpen>Gaussian Blur. In the effect palette, set the blur amount to 6.
14. Create an Adjustment layer (Layers>Adjustment Layer). An Adjustment layer is an empty layer, any effects applied to an adjustment layer will be applied to all of the layers below it.

15. Select the Adjustment layer and choose Effect>Blur and Sharpen>Lens Blur. This applies a lens blur to the all of the layers causing them to be blurred out. To control how the lens blur is applied you’ll use the Depth pass.

16. Drag the depth pass on top of the Adjustment layer. Turn its visibility off.

17. Select the Adjustment layer, in the effects palette set the Depth Map Layer to the Depth Layer, set the Depth Map Channel to Luminance. This uses the luminance of the depth layer to control the blur applied by the Adjustment layer you can change, or even key frame the blur.

18. Click on Invert Depth map, lighter areas will receive less blur, darker areas will receive more blur.

19. Click on Repeat Edge Pixels at the bottom (may only be available in AE CS3) to remove the dark fringe around the border of the composition.

20. To change the amount of blurring, adjust the Iris Radius, to change the depth at which the image is not blurry, adjust the Blur Focus Distance.

**Fine Tuning and Color Correction**

At this point you can use After Effects controls to improve the overall look of the animation.

1. The color of the background is a little garish and distracting. You can fix this by adjusting the colors of the layer. Select the background layer and choose Effect>Color Correction>Hue, Saturation.

2. In the Effect palette set the wheel to 55 degrees and the Master Saturation to -38.

3. The lighting of the background can also be improved by using a mask.

4. Create a new ‘Solid’ layer, in the options palette, set the color of the layer to black.
5. Drag the layer in the timeline so that it’s above the BG layer.
6. Use the circular mask tool to create a mask object.
7. Expand the mask controls in the new layer, set the mask’s mode to subtract to invert the mask.
8. Set mask feather to 170.
9. Lower the opacity of the new layer to 59% so that it darkens the area around the mask.
10. Position the circular mask over the proteins in the comp.
11. Select the BG layer and add a fast blur (Effect>Blur and Sharpen>Fast Blur), set the blurriness to 8. This will add just a little bit more blur to the backdrop to help separate the foreground elements.
12. Save the scene.
13. To see how the scene looks create a RAM preview.
14. The final composite can be seen in the compositing.mov file included with the project files.

**Additional Techniques**

Beyond experimentation with the many effects that come with After Effects (as well as the many others that can be purchased from various companies), the following section provides a few tips and ideas not necessarily tied to the example shown in this tutorial.

**Grouping Layers**

To create a group of layers you can precompose the layers. Simply shift select the layers you want to group in the timeline and choose Layer>Precompose. The precomposed layers are a nested composition within the main composition. You can apply effects to the entire group just by selecting the precomposition and adding an effect the same way you add an effect to a layer. To edit the contents of the precomposition you can locate it in the project window and double click it. It’s a good idea to give your precompositions a descriptive title so that you can keep track of what they contain.

**Ambient Glow**

You can create the look of ambient glow by duplicating (select and press ctrl/cmd + d) a layer or a nested precomposition and placing

---

The masked layer creates a spotlight effect on the background, this helps to focus attention on the proteins and minimize the distraction of the background animation.

A close up of the proteins in the final composite. The ribbons within the protein mesh are darkened and blurred giving the proteins a translucent look.
this duplicate above the original. Set the transfer mode of the duplicate to screen and add a fast blur to it. Increase the blur amount and try lowering the opacity of the duplicate layer.

**Track Mattes**

A track matte can be used to create an animated cut away mask to reveal parts of one layer hidden by another. For instance if you wanted to create a window that allowed a viewer to see the nucleus behind an otherwise opaque cell membrane, you can render the cell membrane layer and the nucleus layer separately. In After Effects place the membrane image sequence above the cell membrane sequence. Create a third layer above the membrane and add a circular mask to this layer. In the membrane layer settings set the TrkMat menu to alpha inverted matte of the layer above. The Mask on the top layer will now mask out the alpha of the membrane layer creating a window to the layer below. This can be animated by setting keyframes on the mask at the top layer. The track matte source layer is automatically turned off. The track matte source layer must always be one layer above the layer using the track matte.

The ambient glow in this animation was created by duplicating the layers, setting the duplicates above the originals, blurring the duplicates and setting their blending mode to screen.

The settings and arrangement of the track matte layer

Track mattes can be combined with masks to selectively reveal parts of a layer hidden beneath another layer. The masks can be animated as well.
**Vector Blur**

Simple hardware rendered particles can benefit from the CC Vector Blur effect found in the Blur and Sharpen menu. Regular point type particles can be made to look as though they are a viscous fluid by applying one or more instances of the CC vector blur effect.

*Hardware rendered particles created and rendered as points in Maya.*

*The look of the particles can be enhanced using multiple instances of the Vector Blur effect in After Effects.*